Vilken dum lösning detta vart då....

Post Reply
Bamsefar
Z-Wave Kung
Posts: 1137
Joined: 25 Nov 2013, 15:06
Location: Stockholm

21 Jul 2019, 22:00

Så jag har sedan en tid tillbaka haft ett litet problem: Status på vissa switchar har inte uppdaterats om man manuellt ändrar dem. Detta gäller Fibaro's switchar på 1*3kW och 2*1.5kW - alltså puckar som man kan fälla in bakom brytarna i väggen.

I vilket fall, av en slump så hade jag en som fungerade dock i badrummet... Trodde jag, det är alltså en 2*1.5kW som sitter i badrummet. Men de som inte fungerar är 1*3kW - trodde jag alltså.

Vad det visar sig vara är att Z-Wave implementationen för HomeSeer är lite udda / buggig eller liknande, så HS3 programvaran klarar bara av att reagerar på S2 switchen på puckarna. Dvs om man har t.ex. en händelse som skall triggas av att någon slår om en brytare så måste den vara kopplad till S2 - för det är bara den statusen som uppdateras. S1 ingången uppdateras ALDRIG vid manuella förändringar. Detta fungerar såklart på Fibaro's egna HomeCenter 2 - men inte på HomeSeer 3.

Work around blir då att man kopplar brytarna för 1*3kW till S2 istf S1, skapar sedan ett jobb som triggas när S2 ändras, och då påverkar S1 via programkod osv. Ja det fungerar ju då såklart, men oj vad onödig kod det blev. Och på 2*1.5kW så har man inte riktigt den fördelen då - finns ingen ingång över så att säga.

Allt för att HomeSeers plugin för Z-Wave verkar hantera S1 på fel sätt. Dum lösning kallas det.
Använder HomeSeer 3 på Linux - attans så här bra har det aldrig varit!

Lua för nybörjare
Post Reply